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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

l Procedures are presented as numbered lists. A single bullet indicates that the procedure
has only one step.

l Bold type is used for the following:
o Keyboard entries that should be typed in their entirety exactly as shown. For
example, “copy file1” means you must type the word copy, then type a space, and
then type file1.

o On-screen prompts and messages, names of options and text boxes, and menu
commands. Menu commands are often separated by greater than signs (>). For
example, “click HFSS > Excitations > Assign >Wave Port.”

o Labeled keys on the computer keyboard. For example, “Press Enter” means to
press the key labeled Enter.

l Italic type is used for the following:
o Emphasis.
o The titles of publications.
o Keyboard entries when a name or a variable must be typed in place of the words in
italics. For example, “copy filename” means you must type the word copy, then
type a space, and then type the name of the file.

l The plus sign (+) is used between keyboard keys to indicate that you should press the
keys at the same time. For example, “Press Shift+F1” means to press the Shift key and,
while holding it down, press the F1 key also. You should always depress the modifier key
or keys first (for example, Shift, Ctrl, Alt, or Ctrl+Shift), continue to hold it/them down, and
then press the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

l The Ribbon occupies the rectangular area at the top of the application window and con-
tains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Draw > Line"
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This instruction means that you should click the Line command on the Draw ribbon tab.
An image of the command icon, or a partial view of the ribbon, is often included with the
instruction.

l Themenu bar (located above the ribbon) is a group of the main commands of an applic-
ation arranged by category such File, Edit, View, Project, etc. An example of a typical user
interaction is as follows:

"On the Filemenu, click theOpen Examples command" means you can click the File
menu and then clickOpen Examples to launch the dialog box.

l Another alternative is to use the shortcut menu that appears when you click the right-
mouse button. An example of a typical user interaction is as follows:

“Right-click and select Assign Excitation >Wave Port” means when you click the right-
mouse button with an object face selected, you can execute the excitation commands
from the shortcut menu (and the corresponding sub-menus).

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. You can also contact your Ansys account manager in order to
obtain this information.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps were
taken or what stages the simulation reached, including software files as applicable. This allows
more rapid and effective debugging.

Help Menu

To access help from the Help menu, click Help and select from the menu:

l [product name] Help - opens the contents of the help. This help includes the help for the
product and itsGetting Started Guides.

l [product name] Scripting Help - opens the contents of the Scripting Guide.
l [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

To access help from the user interface, press F1. The help specific to the active product (design
type) opens.

You can press F1 while the cursor is pointing at a menu command or while a particular dialog
box or dialog box tab is open. In this case, the help page associated with the command or open
dialog box is displayed automatically.
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1 - Introduction
ThisGetting Started Guide describes how to use Skin Depth Seeding in Ansys Electronics
Desktop.

This guide answers the following questions:

l What is Skin Depth seeding?
l Why use seeding?

It also covers the following topics:

l Skin Depth mesh plot visualization
l Improvement compared to older implementation
l Using simple models
l Choosing settings

This guide does not discuss when a user should use Skin Depth Seeding.

What Is Skin Depth Seeding?
Skin Depth seeding is a mesh operation feature of solvers that use the 3D Modeler, including
HFSS and Maxwell 3D.

The Length Basedmesh operations refine the specified objects or surfaces. Skin Depth Based
mesh refinement lets you calculate or specify a skin depth for mesh refinement, as well as the
number of layers of elements to generate within the specified skin depth.

Getting Started with HFSS: Skin Depth Seeding
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The skin depth is the total depth of all layers combined. The Skin Depth setting provides an
easy, alternative approach to creating physical models of each layer using pseudo-sheet bodies.
Creating and adjusting a complex, layered physical model is difficult. Correcting errors is difficult.
But changing the skin depth, surface triangle length, and the number of layers is simple and has
a quick turnaround time. With Skin Depth refinement, the model itself is much easier to adjust.

For example, consider a rotor, drawn as a stack of seven objects:
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Skin Depth Layering on a single object can provide comparable or superior accuracy in the solu-
tion, and is much easier to create and adjust:

To test various stackings with the Skin Depth Layering Method for Mesh Seeding:

l Revert to initial mesh
l Change settings
l Apply mesh ops

To test various stackings using a pseudo body method:

l Recreate the model with different body thicknesses
l Remake the entire initial mesh
l Tau mesher might not be available for all heights

Skin Depth Layering is much easier and faster. In both cases, remember that a layered mesh or
pseudo body modeling is a means to a good solution, not a goal in itself. Using layered elements
for relevant designs is one way to get to a good solution.

For example, where a pseudo model design had 85K tets, the following table shows some dif-
ferent results where the Surface Triangle Length target is given different values.

The layer reporting counts diagonal shifting as failure, even if there are layers.

Introduction 1-3
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Why Use Seeding?
In general, Ansys recommends the use of adaptive meshing. However, in some cases an adapt-
ive solution is not possible. Skin Depth Seeding helps in some of these cases. Additionally,
some users demand Skin Depth Seeding for situations in which they create layered structures to
force the mesh. This affects the robustness of meshing.

Use of Skin Depth Seeding in appropriate projects is a means to arriving at a converged solution
sooner.

In the following figure:

l Green – no seeding, no sheets; raw model pure adaptive solution
l Red – sheet body version
l Blue – new Skin Depth Seeding, but slightly older result; latest result is much better than
the blue as shown before

Introduction 1-4
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Skin Depth Seeding Implementation Change
Prior to 2018, Skin Depth Seeding utilized layered points. The current implementation uses
layered elements.

On Selection > Length Basedmesh seeding occurs on the surface. Inside Selection >
Length Based occurs within the interior volume of the body. These mesh operations do not
involve Skin Depth seeding. Compare the results ofOn Selection > and Inside Selection >
Length Basedmesh operations:

Introduction 1-5

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS: Skin Depth Seeding

While the surface mesh is similar, the use of a clip plane shows that the interior mesh for Inside
Selection is different.

Layered Elements Implementation
Electronics Desktop requires less layering than other EM tools, and other physics. In contrast
with other tools, the Electronics Desktop:

l Does not just look at layered elements
l Pays attention to element count, number of points/elements in the interior

Introduction 1-6
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l Offers incredibly small element counts

Layered Elements can be applied to select faces of solid bodies. Elements are stretched parallel
to the faces and compressed in the normal direction.

General Guidance for Skin Depth Based Refinement
To best understand how Skin Depth refinement works, experiment with simple models to under-
stand refinement behavior. You can test bodies with skin depth seeding in isolation using
scratch projects.

Particularly for models with true curved surfaces (for example, true cylinders), the Curved Sur-
face Meshing setting has a large impact on the layering success rate. To change this or other set-
tings, right-clickMesh in the Project Manager and select Initial Mesh Settings.
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Selecting a very coarse initial mesh results in a low (60%) success rate. Finer meshes easily hit
80%, surging to 95%.

For example, the following figure shows a faceted cylinder with triangles and segments on a
face. The open triangles show imperfect layering, but a very good success rate.
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A true cylinder with similar mesh settings (including a medium resolution for curved surface
meshing) shows a lower success rate.
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Moving the slider two ticks to the right improves the success rate for the true cylinder much more
effectively than a change to Skin Depth Refinement would. In this case, the overall success goes
from 55% to 81%.

Note that the different layers, 0 through 4 in this example, will have different success rates.
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In addition to the options in the Initial Mesh Settings dialog box, you can use Skin Depth Based
Refinement settings to reach a suitable success rate supporting a good solution. To access
these options, right-clickMesh in the Project Manager and select Assign Mesh Operation >
On Selection > Skin Depth Based.
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Reduce Surface Triangle Length target to improve layering success rate, where success is
consistent layering.

Consider the Surface Triangle Length to Mean Skin Depth ratio. For guidance:

l Avoid stretched triangles on the surface
l Get a few points on the interior of faces
l Test a wide range of ratios from 2.5 to 800
l Set a ratio of 100 or above to contribute to a good success rate
l Above 800, mesh tolerance Quality issues come in to play
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Remember that layered meshing is the means to a solution, not the end goal. Layering elements
is one way to get a good solution. Always check the correctness and accuracy of solutions.

Guidance for HFSS for Skin Depth Based Refinement
l For conducting material, you must enable Solve Inside or the feature has no effect.
l Some spiral inductors might obtain a better Q value when Solve Inside is enabled.
l For projects where you solve inside conductors, there may be a subset of models that
benefit.

User Inputs for Skin Depth Based Refinement
For Skin Depth Based refinement to have an effect, the Solve Inside property for the selected
3D object's material must be checked.

Select the faces of the solid body to which you want to apply Skin Depth Based refinement, and
right-clickMesh in the Project Manager. Select Assign Mesh Operation >On Selection >
Skin Depth Based... to display the Skin Depth Based Refinement dialog box.

The Skin Depth is the total depth of all layers combined. Very thin layers may cause a reduction
in mesh quality or unnecessarily cause the generation of a very large mesh. Further regions
refined under this operation and its close neighbors do not participate in solution adaptive refine-
ment. This is another reason to use this seeding operation with caution.

To calculate the skin depth based on the object's material permeability and conductivity and the
frequency at which the mesh will be refined, click Calculate Skin Depth...

The Calculate Skin depth dialog box appears.
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Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS: Skin Depth Seeding

Initial values for Relative Permeability and Conductivity are taken from the Materials library. For
HFSS, the Frequency value is taken from the Solution Setup.

Note:

All three values must be non-zero to obtain a calculated value using this feature.

When you clickOK, the Calculate Skin Depth dialog box disappears and the calculated value
appears in the Skin Depth field of the Skin Depth Based Refinement dialog box.

Note:

You can edit the calculated value or provide your own without using calculation. Check
whether the calculated value is appropriate to fit within the dimensions of the object.

Next, specify a Number of Layers of Elements.

For the number of layers, choose 2, 3, 4 or (at most) 5 layers. First layer thickness = 1/(2n-1) =
0.333, 0.143, 0.0667, 0.0322. The elements are stretched parallel to face, and are compressed
in the normal direction.

Optionally, provide the maximum edge length of the surface mesh in the Surface Triangle
Length text box. The default value is set to 20% of the maximum edge lengths of the bounding
boxes of each selected face.
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The solver will refine the surface triangle mesh (the faces of the tetrahedra touching the surface)
until their edge lengths are less than or equal to the specified value.

By default, the Restrict Number of Surface Elements setting is cleared. This allows the
mesher to use symmetry more effectively. If you restrict the number of surface elements, sym-
metry may be affected. However, in certain cases, you can restrict the number of surface ele-
ments to prevent runaway refinement.

To restrict the number of elements added during refinement of the faces, first observe the estim-
ated number of surface elements in theMaximum Number of Surface Elements text box. Then,
select the Restrict Number of Surface Elements option to enable theMaximum Number of
Surface Elements option. Adjust the specified number of surface elements as desired.

Note:

You cannot edit theMaximum Number of Surface Elements, and the specified number
has no effect on the resulting mesh, until you select the Restrict Number of Surface Ele-
ments option immediately above it.

When the mesh is generated, the refinement criteria you specify are used. This operation is
approximately the same as having slabs of tetrahedra, but it is not guaranteed to prevent tet-
rahedra from crossing slab interfaces. Use caution with this mesh operation, as very thin layers
may cause a reduction in mesh quality or unnecessarily cause the generation of a very large
mesh. Further regions refined under this operation and its close neighbors do not participate in
solution adaptive refinement. This is another reason to use this seeding operation with caution.

Generate Initial Mesh
After defining mesh operations for a model (including Initial Mesh Settings, Skin Depth
Based, or other operations), you can generate an initial mesh without solving the analysis. To do
so, right-click Analysis in the Project Manager and chooseGenerate Mesh from the shortcut
menu.
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After generating a mesh, you can overlay mesh plots and use the Cut Plane features to examine
the appearance of the mesh. Also, right-click Analysis in the Project Manager and choose View
Mesh Feedback to access theMesh Feedback tab of theModel Analysis. Here, you can eval-
uate the success of the mesh and view any problems. TheMesh Error Description box on this
tab provides a statistical evaluation of the overall body's meshing success (expected versus
found triangles) as well as success percentages by count and by area.
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2 - Skin Depth Mesh Plot Visualization
The Modeler provides two ways to visualize meshes:

l Mesh plots and Clip Planes
l TheMesh Feedback tab of theModel Analysis window, which also provides statistics

After generating a mesh, you can create a mesh plot that you can examine using a Clip Plane to
view internal mesh features.

If you did not select the end faces for layers, and if they are at 90 degrees to the selected faces,
you can see some layering in the surface mesh plot.

In some cases, the state of the surface mesh may not indicate the quality of the internal mesh.
Consider an example where layering is very good on the bent faces, but imperfect on the side
faces due to swapped diagonals.

Getting Started with HFSS: Skin Depth Seeding

Skin Depth Mesh Plot Visualization 2-1
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The following figure shows a closer look at a side face, showing the swapped diagonals that
occurred in this case.

A view of the internal layering shows the quality of the overall mesh.

Skin Depth Mesh Plot Visualization 2-2
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For the settings used, the mesh is identical across layers for 95% of the area. Changes to set-
tings can improve the success rate, but a 100% success rate is not required for a good solution
and is not desirable in all cases because it could cause a very large mesh and labored sim-
ulation. Note the different success rates based on different Surface Triangle Length in this
example:

The statistics for success come from theMesh Error Description field of theModel Analysis win-
dow, shown below.

Skin Depth Mesh Plot Visualization 2-3
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Using a Clip Plane to View the Internal Mesh
You can also use the Clipping Planes feature on the View tab of the ribbon (see below) or the
View > Clipping > Clip Planemenu command to view the internal details of a mesh.

After you have created a solution:

1. Select a face of the model.
2. Open the Clip Planes window and click Add > Use Selection.

Skin Depth Mesh Plot Visualization 2-4
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The window shows a defined and enabled clip plane, and the handle is visible as a circle, center
sphere, and direction cones.

The handle may obscure your view of the internal mesh. If this happens, move the clip pane to
the side of the object by performing the following steps:

1. Click the edge of the center circle until you see four green direction arrows.

Skin Depth Mesh Plot Visualization 2-5
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2. Click and drag the handle to the right until it is past the face of the object.

3. To use the clip plane handle, point the cursor at the center of the inner circle until the cone
turns yellow (If the cursor is not at the center, the cone does not change, and four green dir-
ection arrows appear around the inner circle).

From here you can click and drag the clip plane to the right, and watch the clip plane move
through the object, revealing the detail of the inner mesh.

Skin Depth Mesh Plot Visualization 2-6
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A Clip plane can be revealing and insightful but can be difficult to use. Clip plane views can also
be misleading when the plane exposes partial tets at odd locations and makes a good mesh look
bad. Alternatively, you can view mesh data using theModel Analysis window.

Viewing Mesh Feedback to Critique the Internal Mesh
When viewing mesh feedback, do not enable a mesh plot display. After running the Analysis or
clickingGenerate Mesh (in the Analysis shortcut menu), you can right-click Analysis in the Pro-
ject Manager and choose View Mesh Feedback to open theModel Analysis window. If errors
occurred during mesh generation, they are listed under theMesh Feedback tab of this window.

Skin Depth Mesh Plot Visualization 2-7
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Select aMesh Error row from the left panel to populate the right panel with face, triangle, and
segment information.

Skin Depth Mesh Plot Visualization 2-8
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Row 0 on the left shows the face to which Mesh Layering has been assigned. Layer 1 is closest
to the Face. Layer n is farthest. The initial selection on the right side is a comma separated face
list for all faces associated with the body.

TheMesh Error Description box describes the results of the simulation for the selected layer.
The first part lists the Total Expected number of triangles of a given area compared with the total
number of Found triangles. This is followed by the Success percentages by count and by area.

The selected layer row for the left panel affects the Mesh Error Description fields, showing the
results for the selected layer.

Skin Depth Mesh Plot Visualization 2-9
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Getting Started with HFSS: Skin Depth Seeding

Notice that the Layer count changes in theMesh Error Description when you change the row
selection:

Selecting and Viewing Specific Faces
When you select a layer in the Mesh Error panel, a comma-separated list of the associated faces
with mesh errors is selected (highlighted) in the right side panel.

Skin Depth Mesh Plot Visualization 2-10
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TheModeler window shows all the selected faces. Zoom in to see the individual yellow Mesh
Warning triangles comprising the yellow areas.

Subsequent rows in the Mesh Error Panel list error entries by body or face for the selected layer.
If the number of faces for the model is too large to fit the pane, you can resize the window and/or
use the scroll bar. As shown below, selecting a body or face row in theModel Analysis window
also selects the corresponding body or face in theModeler window.

Skin Depth Mesh Plot Visualization 2-11
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You can enable or disable the Hide All Other Objects and Auto zoom features as needed.

Selecting Triangles for a Face
Selecting Triangles from the row under the associated Face selects the triangles on that face.

Skin Depth Mesh Plot Visualization 2-12

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS: Skin Depth Seeding

Triangles that have errors are not colored in. Remember that a good solution using skin depth
mesh operations does not require perfection.

Selecting Segments for a Face
Selecting Segments associated with a Face displays the corresponding segments in the
Modeler window.

Skin Depth Mesh Plot Visualization 2-13
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Viewing Triangles and Segments at the Same Time
Using Shift+click or Ctrl+click, you can select both triangle and segment rows for the most
informative display. Triangles associated with imperfect layering are not colored in.
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You can use the Zoom, Pan, and Rotate commands on the View ribbon to look closely at spe-
cific areas.

Changing Settings in Response to Success Rates and Visualization
Once you have examined the results, you can change the Initial Mesh Settings and Skin
Depth Refinement values to improve the success rate to a suitable result. You can then right-
click Analysis in the Project Manager and clickGenerate Mesh to update the mesh. Then, view
and evaluate the effects of the revised settings on the overall success of the mesh.
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